LNMP下安装wordpress升级故障中两个问题的解决办法

第一个问题:

升级时出现错误提示

执行请求的操作,WordPress需要访问您网页服务器的权限。

一般出现这种错误的原因是wordpress后台没有下载写入覆盖升级文件的权限,这个是服务器端的权限设置问题,不是用户的问题。其实出现这个的问题就是Apache/Nginx的执行身份非文件属主身份。

解决方法:

假设你的wordpress安装目录为/home/wwwroot/wordpress

执行:

chmod -R 755 /home/wwwroot
chown -R www /home/wwwroot

执行上面的命令就可以将/home/wwwroot/wordpress下所有文件的属主改为www,并赋予wwwroot目录可读写的权限。

“www”换成你自己的ftp用户名,“/home/wwwroot/wordpress”换成你自己的wordpress安装目。

这样就可以解决自动更新必须填FTP的问题。

注意:

1,必须是把wordpress程序文件上传到空间以后再执行该命令,顺序不能颠倒;

2,添加完虚拟主机以后,也必须把wordpress程序文件上传到空间以后,再执行该命令才有效!

若出现了这个问题,不仅后台安装不了插件或主题,在ftp的wordpress目录下也是上传不了文件的。

第二个问题:

进入仪表盘后总提示“一些翻译需要更新”,当然点击N遍更新后仍然提示“一些翻译需要更新”。在另一个同样版本的WordPress下却没有问题。一开始觉得是环境配置问题,但是重新配置了一遍生产环境仍然无果,还是提示“一些翻译需要更新”。

原因:

PHP的scandir函数被禁用

解决办法:

修改php.ini文件,搜索scandir,一般在disable_functions后,删除scandir即可解决。

 

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注